summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-05 21:58:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-05 22:17:14 +0200
commit4aeb7f34c948f32363f2ae29c6942c6328df758c (patch)
tree67c4e5263381087046a71ba31acc1c54942ae5fb /gnu
parent66416c0c1cd972857e40dcd89b1c83bbb5cd0257 (diff)
downloadguix-4aeb7f34c948f32363f2ae29c6942c6328df758c.tar.gz
gnu: shflags: Don't use unstable tarball.
* gnu/packages/version-control.scm (shflow)[source]: Use 'git-fetch'.
[native-inputs]: Remove gzip, tar.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 070d86ce7d..b8e967bf69 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015, 2018 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
@@ -914,16 +914,15 @@ either a pure Python implementation, or the faster, but more resource intensive
     (name "shflags")
     (version "1.2.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/kward/shflags/archive/v"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/kward/shflags.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1h9xfrwwdhzflipfwdcgcc3y7zapdslnyk1rg5y8jm7k144rfrs4"))))
+                "1ydx0sb6vz9s2dgp5bd64y7fpzh9qvmlfjxrbmzac8saknijrlly"))))
     (build-system gnu-build-system)
-    (native-inputs `(("tar" ,tar)
-                     ("gzip" ,gzip)))
     (arguments
      `(#:tests? #f                      ; no tests
        #:phases