summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAhriman <ahriman@fedora.email>2022-08-31 19:18:49 +0100
committerLudovic Courtès <ludo@gnu.org>2022-09-06 16:58:12 +0200
commit4b5198acccb5cd298b97825ba0268e19073aebc0 (patch)
tree3b5d35300cd1d1217cca71bd35c1893ca05de60a /gnu
parent0c5e2333ca84122e7c3bc037239bde41ebc98c8d (diff)
downloadguix-4b5198acccb5cd298b97825ba0268e19073aebc0.tar.gz
gnu: Add blueprint-compiler.
* gnu/packages/gnome.scm (blueprint-compiler): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c824f822f6..8791291f78 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3192,6 +3192,31 @@ the GNOME desktop environment.")
                                 (variable "GLADE_MODULE_SEARCH_PATH")
                                 (files '("lib/glade/modules")))))))
 
+(define-public blueprint-compiler
+  (let ((commit "87cedc2c7e48b01dc1b07aef937e2fe02111b18c"))
+    (package
+      (name "blueprint-compiler")
+      (version "0.2.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url
+                       "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+                      (commit commit)))
+                (file-name (string-append name "-" commit "-checkout"))
+                (sha256
+                 (base32
+                  "1mrj5dyjf5d325yc28fpph588qfsz6bm2nx5nnsgcv02bagplxid"))))
+      (build-system meson-build-system)
+      (native-inputs (list gobject-introspection gtk))
+      (inputs (list python))
+      (synopsis "Template markup language")
+      (description
+       "Blueprint is a markup language for GTK user interfaces.  Internally, it
+compiles to GTKBuilder XML.")
+      (home-page "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+      (license license:lgpl3+))))
+
 (define-public cambalache
   (package
    (name "cambalache")