summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-30 15:44:59 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-30 23:16:22 +0200
commit4dfe6c58ee204cf05ce9ef5abbc96ada44ef0784 (patch)
tree981ea44bd864bc59265d0fae95e0f50c063703bf /gnu
parent864068e204faaba44efee940a079ab2a16ba9909 (diff)
downloadguix-4dfe6c58ee204cf05ce9ef5abbc96ada44ef0784.tar.gz
system: Add (guix build activation).
* gnu/services/dmd.scm (dmd-configuration-file): Remove 'etc'
  parameter.  Move /etc activation code to...
* guix/build/activation.scm: ... here; new file.
* gnu/system.scm (operating-system-boot-script): Augment script: add
  (guix build activation) to the load path; call 'activate-etc'.
* Makefile.am (MODULES): Add guix/build/activation.scm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/services/dmd.scm27
-rw-r--r--gnu/system.scm21
2 files changed, 20 insertions, 28 deletions
diff --git a/gnu/services/dmd.scm b/gnu/services/dmd.scm
index c187c09857..161a971edd 100644
--- a/gnu/services/dmd.scm
+++ b/gnu/services/dmd.scm
@@ -30,9 +30,8 @@
 ;;;
 ;;; Code:
 
-(define (dmd-configuration-file services etc)
-  "Return the dmd configuration file for SERVICES, that initializes /etc from
-ETC (the derivation that builds the /etc directory) on startup."
+(define (dmd-configuration-file services)
+  "Return the dmd configuration file for SERVICES."
   (define config
     #~(begin
         (use-modules (ice-9 ftw))
@@ -48,28 +47,6 @@ ETC (the derivation that builds the /etc directory) on startup."
                        #:stop #$(service-stop service)))
                  services))
 
-        ;; /etc is a mixture of static and dynamic settings.  Here is where we
-        ;; initialize it from the static part.
-        (format #t "populating /etc from ~a...~%" #$etc)
-        (let ((rm-f (lambda (f)
-                      (false-if-exception (delete-file f)))))
-          (rm-f "/etc/static")
-          (symlink #$etc "/etc/static")
-          (for-each (lambda (file)
-                      ;; TODO: Handle 'shadow' specially so that changed
-                      ;; password aren't lost.
-                      (let ((target (string-append "/etc/" file))
-                            (source (string-append "/etc/static/" file)))
-                        (rm-f target)
-                        (symlink source target)))
-                    (scandir #$etc
-                             (lambda (file)
-                               (not (member file '("." ".."))))))
-
-          ;; Prevent ETC from being GC'd.
-          (rm-f "/var/guix/gcroots/etc-directory")
-          (symlink #$etc "/var/guix/gcroots/etc-directory"))
-
         ;; guix-daemon 0.6 aborts if 'PATH' is undefined, so work around it.
         (setenv "PATH" "/run/current-system/bin")
 
diff --git a/gnu/system.scm b/gnu/system.scm
index 86904d9be2..4a85857582 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -256,10 +256,25 @@ we're running in the final root."
   (mlet* %store-monad
       ((services (sequence %store-monad (operating-system-services os)))
        (etc      (operating-system-etc-directory os))
-       (dmd-conf (dmd-configuration-file services etc)))
+       (modules  (imported-modules '((guix build activation))))
+       (compiled (compiled-modules '((guix build activation))))
+       (dmd-conf (dmd-configuration-file services)))
     (gexp->file "boot"
-                #~(execl (string-append #$dmd "/bin/dmd")
-                         "dmd" "--config" #$dmd-conf))))
+                #~(begin
+                    (eval-when (expand load eval)
+                      ;; Make sure 'use-modules' below succeeds.
+                      (set! %load-path (cons #$modules %load-path))
+                      (set! %load-compiled-path
+                            (cons #$compiled %load-compiled-path)))
+
+                    (use-modules (guix build activation))
+
+                    ;; Populate /etc.
+                    (activate-etc #$etc)
+
+                    ;; Start dmd.
+                    (execl (string-append #$dmd "/bin/dmd")
+                           "dmd" "--config" #$dmd-conf)))))
 
 (define (operating-system-derivation os)
   "Return a derivation that builds OS."