summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:00:17 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:00 +0100
commit54f11f47b508d759c7b28ad998d5b50a5504110e (patch)
tree69a4e8e905247b45f0c7053d6de7cf541ec16381 /gnu
parent545fc7285b84833ab9d097a40be2a7e5d06ddc06 (diff)
downloadguix-54f11f47b508d759c7b28ad998d5b50a5504110e.tar.gz
gnu: Add rust-propfuzz-0.0.1.
* gnu/packages/crates-io.scm (rust-propfuzz-0.0.1): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8833602e3e..1e44b4b7f0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -42268,6 +42268,30 @@ status.")
 progress-bars for Rust.")
     (license license:asl2.0)))
 
+(define-public rust-propfuzz-0.0.1
+  (package
+    (name "rust-propfuzz")
+    (version "0.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "propfuzz" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1xadkjqsnnazfksaywxkdgv0fjkclj2p7x36r044jbj9g395nxyg"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #t
+           #:cargo-inputs
+           `(("rust-propfuzz-macro" ,rust-propfuzz-macro-0.0.1)
+             ("rust-proptest" ,rust-proptest-0.10))))
+    (home-page "https://github.com/facebookincubator/propfuzz")
+    (synopsis "Property-based testing and fuzzing")
+    (description
+     "This package provides a Rust library that combines
+property-based testing and fuzzing.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-propfuzz-macro-0.0.1
   (package
     (name "rust-propfuzz-macro")