summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-22 19:44:07 +0000
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:21:47 +0200
commit56d8907c5ffbe9422f1b159759653715ded9d45a (patch)
tree2402afe75bc0e193f2b342a4fd53e3d2b5259e88 /gnu
parentdec74d456365ae2d57213cbf0d0a9fd726600cbe (diff)
downloadguix-56d8907c5ffbe9422f1b159759653715ded9d45a.tar.gz
gnu: Add python-sarif-om.
* gnu/packages/python-web.scm (python-sarif-om): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2517201722..c088f3a8dc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -777,6 +777,26 @@ for resource properties and best practices.")
 @url{http://jschema.org,JSchema} JSON schema.")
     (license license:expat)))
 
+(define-public python-sarif-om
+  (package
+    (name "python-sarif-om")
+    (version "1.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sarif_om" version))
+              (sha256
+               (base32
+                "167gb8xjm0310km3w1s12bqldbv7zyklkr4j5900vq4361ml2pyd"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-attrs))
+    (native-inputs (list python-pbr))
+    (home-page "https://github.com/microsoft/sarif-python-om")
+    (synopsis "Python implementation of the SARIF 2.1.0 object model.")
+    (description "This module contains classes for the object model defined
+by the @url{https://sarifweb.azurewebsites.net,Static Analysis Results
+Interchange Format (SARIF)} file format.")
+    (license license:expat)))
+
 (define-public python-falcon
   (package
     (name "python-falcon")