summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:09:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:19 +0200
commit5c7346c2345c48558c5b559c55c6b18cb6f07635 (patch)
treed0d3acaa05589a517a864e2d085bb2109f2ee060 /gnu
parent3a38961b11536d45cdf6d662c3ddb5f7d2e4054e (diff)
downloadguix-5c7346c2345c48558c5b559c55c6b18cb6f07635.tar.gz
gnu: texlive-lm-math: Refresh package definition.
* gnu/packages/tex.scm (texlive-lm-math): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 31c7bcdea6..66e1a3b3fb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1426,18 +1426,22 @@ Computers & Typesetting series.")
 
 (define-public texlive-lm-math
   (package
-    (inherit (simple-texlive-package
-              "texlive-lm-math"
-              (list "/doc/fonts/lm-math/"
-                    "/fonts/opentype/public/lm-math/")
-              (base32
-               "0gqdk8x3r1iz4n8j6r3pcqbwalxvkihayvmjfq4iv6hwb0pvys8z")
-              #:trivial? #t))
-    (home-page "https://www.gust.org.pl/projects/e-foundry/latin-modern")
+    (name "texlive-lm-math")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/lm-math/"
+                   "fonts/opentype/public/lm-math/")
+             (base32
+              "0gqdk8x3r1iz4n8j6r3pcqbwalxvkihayvmjfq4iv6hwb0pvys8z")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lm-math")
     (synopsis "OpenType maths fonts for Latin Modern")
-    (description "Latin Modern Math is a maths companion for the Latin Modern
-family of fonts, in OpenType format.  For use with LuaLaTeX or XeLaTeX,
-support is available from the @code{unicode-math} package.")
+    (description
+     "Latin Modern Math is a maths companion for the Latin Modern family of
+fonts, in OpenType format.  For use with LuaLaTeX or XeLaTeX, support is
+available from the @code{unicode-math} package.")
     (license license:gfl1.0)))
 
 (define-public texlive-lwarp