summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2023-01-08 10:30:41 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-01-08 17:46:50 +0100
commit619cb50199d61489a02198389b9ed22af18505b3 (patch)
tree89100b71a054a4096aba89ca3b5b00a7ad3cfe44 /gnu
parent7a9edf4324731fe77c652a9dddff61dfa859e0c4 (diff)
downloadguix-619cb50199d61489a02198389b9ed22af18505b3.tar.gz
gnu: pipewire: Enable more features.
* gnu/packages/linux.scm (pipewire)[inputs]:
Add
- libfdk for ACC support over bluetooth
- libfreeaptx for aptX support over bluetooth
- libsndfile
- libusb for bluetooth support
- lilv for lv2 plugins
- webrtc-audio-processing for noise cancelling
- readline for pw-cli

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c737edde2..4b21f9ca33 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9110,11 +9110,18 @@ types and interfaces and translates so that the X server can use them.")
                   gstreamer
                   jack-2
                   ldacbt
+                  libfdk
+                  libfreeaptx
+                  libsndfile
+                  libusb
+                  openssl ; raop sink
                   libva
                   pulseaudio
+                  readline ; for pw-cli
                   sbc
                   vulkan-headers
-                  vulkan-loader))
+                  vulkan-loader
+                  webrtc-audio-processing))
     (home-page "https://pipewire.org/")
     (synopsis "Server and user space API to deal with multimedia pipelines")
     (description