summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-22 10:35:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-22 10:35:58 +0200
commit662316b0d6edcb838a4a70fc329660d425f5fe79 (patch)
tree5ad23fc9b7cef931476388bcae9b7b261456a4f8 /gnu
parentb6fc274637c69929e7811b40bf9b99d3e8df8360 (diff)
downloadguix-662316b0d6edcb838a4a70fc329660d425f5fe79.tar.gz
gnu: widelands: Ensure Guix catches versioning scheme switch.
* gnu/packages/games.scm (widelands-21): New variable.

"21" was the last beta release.  Upstream has now switched to a new versioning
scheme, with lesser numbers.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9944c0dcc6..1da5fa468d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5303,6 +5303,12 @@ of war.  Widelands also offers an Artificial Intelligence to challenge you.")
                    license:silofl1.1       ;Widelands.ttf
                    license:cc-by-sa3.0)))) ;some music files
 
+(define-public widelands-21
+  (package
+    (inherit widelands)
+    (version "21")
+    (properties `((superseded . ,widelands)))))
+
 (define-public starfighter
   (package
     (name "starfighter")