summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-05 19:47:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-05 19:48:23 +0100
commit66416c0c1cd972857e40dcd89b1c83bbb5cd0257 (patch)
tree40ed086a4806cf9aa553476fd0ee9c52da9a4100 /gnu
parentcfc92cd7bfbd1a7c553b4b8b21e6cc34fcbd53c7 (diff)
downloadguix-66416c0c1cd972857e40dcd89b1c83bbb5cd0257.tar.gz
gnu: cvs-fast-export: Update to 1.45.
* gnu/packages/version-control.scm (cvs-fast-export): Update to 1.45.
[arguments]: Remove 'fix-setpython-PATH' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c6bde297b4..070d86ce7d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1427,27 +1427,19 @@ RCS, PRCS, and Aegis packages.")
 (define-public cvs-fast-export
   (package
     (name "cvs-fast-export")
-    (version "1.44")
+    (version "1.45")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.catb.org/~esr/cvs-fast-export/"
                                   "cvs-fast-export-" version ".tar.gz"))
               (sha256
                (base32
-                "1l7hlys4vw4zk4ikdjiig5vzgv5dv48mbm8bdqgvgkyyxb2j0dm0"))))
+                "19pxg6p0pcgyd2fbnh3wy1kazv6vcfi5lzc2whhdi1w9kj4r9c4z"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (delete 'configure)
-         (add-before 'check 'fix-setpython-PATH
-           (lambda _
-             ;; The Makefile does try to add the current working directory to
-             ;; $PATH, but this fails for some reason in 1.44.  Hack around it.
-             (substitute* "tests/Makefile"
-               (("setpython" command)
-                (string-append "./" command)))
-             #t))
+         (delete 'configure)            ; no configure script
          (add-after 'unpack 'remove-optimizations
            (lambda _
              ;; Don't optimize for a specific processor architecture.