summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-11 12:20:29 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:06 -0500
commit786ccb71cce8ccc2a77e5b2b0622070485ed7b57 (patch)
tree44a0628f4c6f90a2343c506ef67cdbe8a2f83203 /gnu
parent83e825a16eca8e17023221fa55dc08b289cf70be (diff)
downloadguix-786ccb71cce8ccc2a77e5b2b0622070485ed7b57.tar.gz
gnu: Add Test-SharedFork.
* gnu/packages/perl.scm (perl-test-sharedfork): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index abbc22d3e4..39239c9daa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2107,6 +2107,27 @@ bin as is also commonly used) paths of your Perl distribution.")
                               "Test-Script-" version))
     (license (package-license perl))))
 
+(define-public perl-test-sharedfork
+  (package
+    (name "perl-test-sharedfork")
+    (version "0.29")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
+                           "Test-SharedFork-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0vlak10q4gcf0ch0rfcb9lvddav6r8h15iipzbkbgf9mrj47gbv3"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-requires" ,perl-test-requires)))
+    (home-page "http://search.cpan.org/dist/Test-SharedFork")
+    (synopsis "Fork test in Perl")
+    (description "Test::SharedFork is a utility module for Test::Builder.  It
+makes fork(2) safe to use in test cases.")
+    (license (package-license perl))))
+
 (define-public perl-test-simple
   (package
     (name "perl-test-simple")