summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-19 23:43:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-10-20 00:03:40 +0200
commit79624befa1a41e0ea237a4654209a1c08524374c (patch)
tree296eec9b19110885dbc8ae217631a0a7a8db0d58 /gnu
parent615ee12e64ced278389e2ac8b64eca19a9ff688d (diff)
downloadguix-79624befa1a41e0ea237a4654209a1c08524374c.tar.gz
gnu: r-with-tests: Work around reproducibility problem.
Fixes <https://bugs.gnu.org/35441>.

* gnu/packages/statistics.scm (r-with-tests)[arguments]: Avoid reproducibility
problem by patching problematic sequence of characters in DESCRIPTION file
template.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index bebd574f41..3f65e6afa5 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -269,6 +269,15 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
                (substitute* "tools/help2man.pl"
                  (("my \\$date = strftime \"%B %Y\", localtime" line)
                   (string-append line " 1"))))
+
+             ;; The "References" section of this file when converted to
+             ;; package.rds is sometimes stored with a newline, sometimes with
+             ;; a space.  We avoid this problem by adding characters to break
+             ;; up the series of line break and spaces that is suspected to be
+             ;; the culprit.
+             (substitute* "src/library/methods/DESCRIPTION.in"
+               (("  ``Software")
+                "  -- ``Software"))
              #t))
          (add-before 'build 'set-locales
            (lambda _