summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-30 22:44:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:48 +0200
commit82f22fac9f6e7bd9aab420b24a371f5d692533c6 (patch)
treec065217537da8698b85daadf5006bdf042faa5a5 /gnu
parentaa945bf6378b6edcca0502ff7ec6abe57d904405 (diff)
downloadguix-82f22fac9f6e7bd9aab420b24a371f5d692533c6.tar.gz
gnu: lchat: Update to 0.0.0-3.f951919.
* gnu/packages/suckless.scm (lchat): Update to 0.0.0-3.f951919.
[arguments]: Run tests.  Install man page.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/suckless.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 5144d90186..f127a7b94a 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -680,8 +680,8 @@ as -1, to be used instead of U+FFFD.
 
 ;; No release tarballs so far.
 (define-public lchat
-  (let ((revision "2")
-        (commit "25d90f4630b45e2b609d2e3daecb32cf5ff065fd"))
+  (let ((revision "3")
+        (commit "f95191970fd59c52a8b09cff32bd8d2135cbfc6b"))
     (package
       (name "lchat")
       (version (string-append "0.0.0-" revision "." (string-take commit 7)))
@@ -694,24 +694,26 @@ as -1, to be used instead of U+FFFD.
          (file-name (string-append name "-" version "-checkout"))
          (sha256
           (base32
-           "0dvljyq3m7rxxkqv7rkmijak6vj8i4db3iq2z988bvf76chz268b"))))
+           "07pxzziczhzprmjy61k7nl9i1kxpgnad37qkjf5fn4wf06nqdxpl"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f ; No tests
+       `(#:test-target "test"
          #:make-flags (list "CC=gcc"
                             (string-append "PREFIX=" %output))
          #:phases
          (modify-phases %standard-phases
-           (delete 'configure) ; No configure script
+           (delete 'configure)          ; no configure script
            (add-before 'build 'libbsd
              (lambda _
                (substitute* "Makefile"
                  (("-lutf") "-lutf -lbsd"))))
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin")))
+               (let* ((out  (assoc-ref outputs "out"))
+                      (bin  (string-append out "/bin"))
+                      (man1 (string-append out "/share/man/man1")))
                  (install-file "lchat" bin)
+                 (install-file "lchat.1" man1)
                  #t))))))
       (inputs
        `(("grep" ,grep)