summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 14:20:10 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:04 -0500
commit83261658fb5c4b8f5f67d0f157ad3549654f4019 (patch)
treee5210f4a7fb840dbfaa492d1038839587a2d0a54 /gnu
parent13b2552cdbdc47eb64296c5ec88030f9652389e3 (diff)
downloadguix-83261658fb5c4b8f5f67d0f157ad3549654f4019.tar.gz
gnu: Add Catalyst-View-Download.
* gnu/packages/web.scm (perl-catalyst-view-download): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2dafc56865..d0cad375b2 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1075,6 +1075,32 @@ behind a proxy.  Using this module, the request base ($c->req->base) is
 replaced with the contents of the X-Request-Base header.")
     (license (package-license perl))))
 
+(define-public perl-catalyst-view-download
+  (package
+    (name "perl-catalyst-view-download")
+    (version "0.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/G/GA/GAUDEON/"
+                           "Catalyst-View-Download-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1qgq6y9iwfbhbkbgpw9czang2ami6z8jk1zlagrzdisy4igqzkvs"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+       ("perl-test-simple" ,perl-test-simple)
+       ("perl-test-www-mechanize-catalyst" ,perl-test-www-mechanize-catalyst)
+       ("perl-text-csv" ,perl-text-csv)
+       ("perl-xml-simple" ,perl-xml-simple)))
+    (home-page "http://search.cpan.org/dist/Catalyst-View-Download")
+    (synopsis "Download data in many formats")
+    (description "The purpose of this module is to provide a method for
+downloading data into many supportable formats.  For example, downloading a
+table based report in a variety of formats (CSV, HTML, etc.). ")
+    (license (package-license perl))))
+
 (define-public perl-catalystx-component-traits
   (package
     (name "perl-catalystx-component-traits")