summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-09-22 19:25:36 -0400
committerMark H Weaver <mhw@netris.org>2018-09-23 04:55:54 -0400
commit84b334362ebb7fb2e8bc0ec4df1d8b28aabe2413 (patch)
tree3910b6c1eeeaf529fe043038e246006fece63e2b /gnu
parent480d39a600701621e4d5938c8753b8487baa2c7f (diff)
downloadguix-84b334362ebb7fb2e8bc0ec4df1d8b28aabe2413.tar.gz
gnu: eolie: Use webkitgtk-2.22.
* gnu/packages/gnome.scm (eolie)[native-inputs]: Add gcc-7:lib.
[inputs]: Replace webkitgtk with webkitgtk-2.22.
[arguments]: Add "gcc:lib" to the list of libraries to add to
LD_LIBRARY_PATH.  Use invoke.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f9c9f1cf5c..9f5ede8b07 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4104,19 +4104,20 @@ work and the interface is well tested.")
          (delete 'configure)
          (replace 'build
            (lambda* (#:key outputs #:allow-other-keys)
-             (zero? (system* "meson" "build"
-                             "--prefix" (assoc-ref outputs "out")))))
+             (invoke "meson" "build"
+                      "--prefix" (assoc-ref outputs "out"))))
          (replace 'check
-           (lambda _ (zero? (system* "ninja" "-C" "build" "test"))))
+           (lambda _ (invoke "ninja" "-C" "build" "test")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
-             (zero? (system* "ninja" "-C" "build" "install"))))
+             (invoke "ninja" "-C" "build" "install")))
          (add-after 'wrap 'wrap-more
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
                     ;; These libraries must be on LD_LIBRARY_PATH.
                     (libs '("gtkspell3" "webkitgtk" "libsoup" "libsecret"
                             "atk" "gtk+" "gsettings-desktop-schemas"
+                            "gcc:lib" ; needed b/c webkitgtk is built with gcc-7
                             "gobject-introspection"))
                     (path (string-join
                            (map (lambda (lib)
@@ -4129,7 +4130,8 @@ work and the interface is well tested.")
                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))
              #t)))))
     (native-inputs
-     `(("intltool" ,intltool)
+     `(("gcc:lib" ,gcc-7 "lib") ; needed because webkitgtk is built with gcc-7
+       ("intltool" ,intltool)
        ("itstool" ,itstool)
        ("pkg-config" ,pkg-config)
        ("meson" ,meson-for-build)
@@ -4149,7 +4151,7 @@ work and the interface is well tested.")
        ("libsecret" ,libsecret)
        ("gtkspell3" ,gtkspell3)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("webkitgtk" ,webkitgtk)))
+       ("webkitgtk" ,webkitgtk-2.22)))
     (home-page "https://wiki.gnome.org/Apps/Eolie")
     (synopsis "Web browser for GNOME")
     (description