summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-11-22 21:12:34 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2020-12-29 20:24:10 +0100
commit95787bf4eda7728c2f352e37891edd644c610bda (patch)
tree7d9642013ae76bc9e83e3831da0a1aa02abcbeaa /gnu
parent4f196b0a9e74d6f02a08fd6fda08279034ae1629 (diff)
downloadguix-95787bf4eda7728c2f352e37891edd644c610bda.tar.gz
gnu: Update and deprecate gst-transcoder.
As of 1.18, gst-transcoder is part of gst-plugins-bad.

* gnu/packages/video.scm (gst-transcoder): Move from here...
* gnu/packages/gstreamer.scm (gst-transcoder): ... to here.
Redefine in terms of gst-plugins-bad and deprecate in favor of it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm7
-rw-r--r--gnu/packages/video.scm28
2 files changed, 7 insertions, 28 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 3b572b9f07..944eba03d9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -934,6 +934,13 @@ given, also pass them to the build system instead of the ones used by PKG."
                     (("'auto'") "'disabled'"))
                   #t)))))))))
 
+(define-public gst-transcoder
+  (deprecated-package
+   "gst-transcoder"
+   (gst-plugins/selection gst-plugins-bad
+                          #:plugins '("transcoder")
+                          #:configure-flags '("-Dintrospection=enabled"))))
+
 (define-public python-gst
   (package
     (name "python-gst")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c369e9ece2..949b51c568 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4004,34 +4004,6 @@ tools for styling them, including a built-in real-time video preview.")
    ; by upstream). See https://github.com/Aegisub/Aegisub/blob/master/LICENCE
    ; src/MatroskaParser.(c|h) is under bsd-3 with permission from the author
 
-(define-public gst-transcoder
-  (package
-    (name "gst-transcoder")
-    (version "1.12.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/pitivi/gst-transcoder")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0nw1zykqc6c8xs3ri55pm00pwyz93z4y4nd880apfiwj7yv5p3az"))))
-    (build-system meson-build-system)
-    (inputs
-     `(("gobject-introspection" ,gobject-introspection)
-       ("glib" ,glib)
-       ("gstreamer" ,gstreamer)
-       ("gst-plugins-base" ,gst-plugins-base)))
-    (native-inputs
-     `(("python" ,python)
-       ("pkg-config" ,pkg-config)))
-    (home-page "https://github.com/pitivi/gst-transcoder/")
-    (synopsis "GStreamer Transcoding API")
-    (description "GStreamer Transcoding API")
-    (license license:lgpl2.1)))
-
 (define-public gavl
   (package
     (name "gavl")