summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-25 00:31:41 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-25 00:31:41 +0200
commit9e57c1b58742c5eda3edcccd9397ef28dbfb7f5e (patch)
treeac039137a7b9baa45c1bf826393b4ec6604ff52d /gnu
parent707d3e24a23774b8c2e0c6b287de8d6554fae078 (diff)
downloadguix-9e57c1b58742c5eda3edcccd9397ef28dbfb7f5e.tar.gz
gnu: doxygen: Add propagated input graphviz.
* gnu/packages/doxygen.scm (doxygen): Add propagated input graphviz.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/doxygen.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/doxygen.scm b/gnu/packages/doxygen.scm
index c63a3e6ea1..8c51ae858e 100644
--- a/gnu/packages/doxygen.scm
+++ b/gnu/packages/doxygen.scm
@@ -24,6 +24,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages python))
@@ -42,16 +43,14 @@
              (patches (list (search-patch "doxygen-tmake.patch")
                             (search-patch "doxygen-test.patch")))))
     (build-system gnu-build-system)
-    ;; The presence of graphviz is checked, but it does not seem to influence
-    ;; the output: Even after adding it as an input, no reference to it is
-    ;; retained. It might be an option to add it as a propagated input,
-    ;; only so that it becomes installed in the user profile.
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
        ("libxml2" ,libxml2) ; provides xmllint for the tests
        ("perl" ,perl) ; for the tests
        ("python" ,python-2))) ; for creating the documentation
+    (propagated-inputs
+     `(("graphviz" ,graphviz)))
     (arguments
      `(#:test-target "test"
        #:phases