summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-28 20:20:52 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-28 20:20:52 +0200
commitba948b4fa0a088f42815aa104e651c9d14d8a1ba (patch)
tree04553907e90cde6ff3fef0e9e4ccb762531f9553 /gnu
parentc69fe8306d7fa69fa67c31b296ae25353f73a2a0 (diff)
downloadguix-ba948b4fa0a088f42815aa104e651c9d14d8a1ba.tar.gz
gnu: soprano: Add input clucene.
* gnu/packages/rdf.scm (soprano): Add input clucene and patch the cmake
    file looking for it.
* gnu/packages/patches/soprano-find-clucene.patch: New file.
* gnu-system.am (dist_patch_DATA): Register the patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/soprano-find-clucene.patch15
-rw-r--r--gnu/packages/rdf.scm6
2 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/patches/soprano-find-clucene.patch b/gnu/packages/patches/soprano-find-clucene.patch
new file mode 100644
index 0000000000..cc2707853a
--- /dev/null
+++ b/gnu/packages/patches/soprano-find-clucene.patch
@@ -0,0 +1,15 @@
+Search for clucene include file in the clucene include directory.
+
+diff -u -r soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake soprano-2.9.4/cmake/modules/FindCLucene.cmake
+--- soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake	2013-10-09 19:22:28.000000000 +0200
++++ soprano-2.9.4/cmake/modules/FindCLucene.cmake	2014-04-28 20:08:11.000000000 +0200
+@@ -77,7 +77,8 @@
+ 
+ get_filename_component(TRIAL_LIBRARY_DIR ${CLUCENE_LIBRARY} PATH)
+ find_path(CLUCENE_LIBRARY_DIR
+-  NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} NO_DEFAULT_PATH)
++  NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} ${CLUCENE_INCLUDE_DIR} NO_DEFAULT_PATH)
++message (STATUS "XXX ${CLUCENE_LIBRARY_DIR}")
+ if(CLUCENE_LIBRARY_DIR)
+   message(STATUS "Found CLucene library dir: ${CLUCENE_LIBRARY_DIR}")
+   file(READ ${CLUCENE_LIBRARY_DIR}/CLucene/clucene-config.h CLCONTENT)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index b297b5209b..368245bbaa 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -106,15 +106,15 @@ Java Lucene text search engine API to C++.")
                                 "soprano-" version ".tar.bz2"))
              (sha256
               (base32
-               "1rg0x7yg0a1cbnxz7kqk52580wla8jbnj4d4r3j7l7g7ajyny1k4"))))
+               "1rg0x7yg0a1cbnxz7kqk52580wla8jbnj4d4r3j7l7g7ajyny1k4"))
+             (patches (list (search-patch "soprano-find-clucene.patch")))))
     (build-system cmake-build-system)
     ;; FIXME: Add optional dependencies: Redland, odbci.
     (native-inputs
      `(("doxygen" ,doxygen)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("clucene" ,clucene) ; is not yet "fully found", but sufficiently
-                            ; so to allow for compilation...
+     `(("clucene" ,clucene)
        ("qt" ,qt-4)
        ("raptor2" ,raptor2)))
     (home-page "http://soprano.sourceforge.net/")