summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-05-03 17:22:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-05-03 18:26:29 +0200
commitcef3f14644d86391a6e9a814dca4bfd500bc064f (patch)
treef5d1b527dd1a370b2cf73174c15a9c0570775b27 /gnu
parent69daee23af49aeafcb1d250c90860f9253da719e (diff)
downloadguix-cef3f14644d86391a6e9a814dca4bfd500bc064f.tar.gz
gnu: tlp: Install all files.
* gnu/packages/linux.scm (tlp)[arguments]: Add ‘fix-installation’ phase so
the installation no longer aborts half-way, and use ‘zero?’ in the install
phase so this cannot go undetected again.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a5a2ea3e0c..9db8be94a8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3658,7 +3658,7 @@ Light is the successor of lightscript.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (delete 'configure)
+         (delete 'configure)            ; no configure script
          (add-before 'build 'setenv
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
@@ -3673,10 +3673,14 @@ Light is the successor of lightscript.")
                (setenv "TLP_SHCPL"
                        (string-append out "/share/bash-completion/completions"))
                (setenv "TLP_MAN" (string-append out "/share/man")))))
-         (delete 'check)
+         (delete 'check)                ; no tests
+         (add-before 'install 'fix-installation
+           (lambda _
+             ;; Stop the Makefile from trying to create system directories.
+             (substitute* "Makefile" (("\\[ -f \\$\\(_CONF\\) \\]") "#"))))
          (replace 'install
            (lambda _
-             (system "make install-tlp install-man")))
+             (zero? (system* "make" "install-tlp" "install-man"))))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((bin (string-append (assoc-ref outputs "out") "/bin"))