summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:47:50 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commitd9e6af909043d331ba3200d878b7754f27fc5947 (patch)
tree19ecf840a20b26c1f9c66a1a3670a4e42f5178ab /gnu
parentf9f64440f72a161ddb960eede101cd5a606922a2 (diff)
downloadguix-d9e6af909043d331ba3200d878b7754f27fc5947.tar.gz
gnu: Add Package-Stash.
* gnu/packages/perl.scm (perl-package-stash): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 76885d6a56..de3b77e5f9 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -460,6 +460,35 @@ independent of the main namespace and only available through an object
 instance, not by name.")
     (license (package-license perl))))
 
+(define-public perl-package-stash
+  (package
+    (name "perl-package-stash")
+    (version "0.37")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
+                           "Package-Stash-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0b3vg2nbzmz1m5qla4123rmfzmpfmwxkw78fghvwsc4iiww0baq6"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
+       ("perl-test-fatal" ,perl-test-fatal)
+       ("perl-test-requires" ,perl-test-requires)
+       ("perl-package-anon" ,perl-package-anon)))
+    (propagated-inputs
+     `(("perl-module-implementation" ,perl-module-implementation)
+       ("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
+       ("perl-package-stash-xs" ,perl-package-stash-xs)))
+    (home-page "http://search.cpan.org/dist/Package-Stash")
+    (synopsis "Routines for manipulating stashes")
+    (description "Manipulating stashes (Perl's symbol tables) is occasionally
+necessary, but incredibly messy, and easy to get wrong.  This module hides all
+of that behind a simple API.")
+    (license (package-license perl))))
+
 (define-public perl-package-stash-xs
   (package
     (name "perl-package-stash-xs")