summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:17:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:17:23 +0300
commite3e33b5251e11beb0c77cc39f335a5116ab36f9c (patch)
treee1ba158f32d66f7c5712a48e7c63a2a638d0698d /gnu
parent544ff0b6c2b189b61ae2fa252e6e5233420d06a5 (diff)
downloadguix-e3e33b5251e11beb0c77cc39f335a5116ab36f9c.tar.gz
gnu: shishi: Build with newer linux-pam.
* gnu/packages/kerberos.scm (shishi)[inputs]: Replace linux-pam-1.2 with
linux-pam.
* gnu/packages/linux.scm (linux-pam-1.2): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kerberos.scm2
-rw-r--r--gnu/packages/linux.scm15
2 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index a52d4b42cc..8f2bbd1c13 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -147,7 +147,7 @@ cryptography.")
     (inputs
      (list gnutls
            libidn
-           linux-pam-1.2
+           linux-pam
            zlib
            libgcrypt
            libtasn1))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67ca86cbb0..48e58c035d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1660,21 +1660,6 @@ be used through the PAM API to perform tasks, like authenticating a user
 at login.  Local and dynamic reconfiguration are its key features.")
     (license license:bsd-3)))
 
-(define-public linux-pam-1.2
-  (package
-    (inherit linux-pam)
-    (version "1.2.1")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append
-            "http://www.linux-pam.org/library/"
-            "Linux-PAM-" version ".tar.bz2"))
-      (sha256
-       (base32
-        "1n9lnf9gjs72kbj1g354v1xhi2j27aqaah15vykh7cnkq08i4arl"))
-      (patches (search-patches "linux-pam-no-setfsuid.patch"))))))
-
 (define-public python-pamela
   (package
     (name "python-pamela")