summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 20:36:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-07 20:36:19 +0300
commiteed987855ced6d1774326cf5b261680727c5d65a (patch)
treeecfc8d16fce178731b07bbd3de275e70ecc35680 /gnu
parentf63ef9ab0de9f3cce6e573f548e9dabcf5e6be7f (diff)
downloadguix-eed987855ced6d1774326cf5b261680727c5d65a.tar.gz
gnu: msmtp: Use G-Expressions.
* gnu/packages/mail.scm (msmtp)[arguments]: Rewrite using G-Expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d0839fbe09..c31361b6a5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1736,22 +1736,24 @@ addons which can add many functionalities to the base client.")
      (list pkg-config))
     (home-page "https://marlam.de/msmtp/")
     (arguments
-     `(#:configure-flags (list "--with-libgsasl"
-                               "--with-libidn"
-                               "--with-tls=gnutls")
+     (list
+       #:configure-flags
+       #~(list "--with-libgsasl"
+               "--with-libidn"
+               "--with-tls=gnutls")
        #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-additional-files
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (doc (string-append out "/share/doc/msmtp"))
-                    (msmtpq "scripts/msmtpq")
-                    (vimfiles (string-append out "/share/vim/vimfiles/syntax")))
-               (install-file (string-append msmtpq "/msmtpq") bin)
-               (install-file (string-append msmtpq "/msmtp-queue") bin)
-               (install-file (string-append msmtpq "/README.msmtpq") doc)
-               (install-file "scripts/vim/msmtp.vim" vimfiles)))))))
+       #~(modify-phases %standard-phases
+           (add-after 'install 'install-additional-files
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out #$output)
+                      (bin (string-append out "/bin"))
+                      (doc (string-append out "/share/doc/msmtp"))
+                      (msmtpq "scripts/msmtpq")
+                      (vimfiles (string-append out "/share/vim/vimfiles/syntax")))
+                 (install-file (string-append msmtpq "/msmtpq") bin)
+                 (install-file (string-append msmtpq "/msmtp-queue") bin)
+                 (install-file (string-append msmtpq "/README.msmtpq") doc)
+                 (install-file "scripts/vim/msmtp.vim" vimfiles)))))))
     (properties
      '((release-monitoring-url . "https://marlam.de/msmtp/download/")))
     (synopsis