summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-14 16:32:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 13:02:53 -0400
commitf1f6ede7f802f3b9113192a5947ead105af6e06f (patch)
tree1cc9d8ceeec90e2903e2dfd15c7dcee22ea60637 /gnu
parentc61ea717b05e37b8ea80f1cd2f2811459117f60c (diff)
downloadguix-f1f6ede7f802f3b9113192a5947ead105af6e06f.tar.gz
gnu: Add python-robotframework-seleniumlibrary.
* gnu/packages/python-xyz.scm (python-robotframework-seleniumlibrary): New
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4ae5844f7..d35afa5bf9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4553,6 +4553,30 @@ interface and by handling all the requirements towards the Robot Framework
 library APIs.")
     (license license:asl2.0)))
 
+(define-public python-robotframework-seleniumlibrary
+  (package
+    (name "python-robotframework-seleniumlibrary")
+    (version "5.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "robotframework-seleniumlibrary" version))
+       (sha256
+        (base32 "1dihrbcid9i7daw2qy6h3xsvwaxzmyip820jw5z11n60qrl006pm"))))
+    (build-system python-build-system)
+    ;; XXX: Tests require ungoogled-chromium, but the chromium module would
+    ;; introduce a cycle if imported here.
+    (propagated-inputs
+     `(("python-robotframework" ,python-robotframework)
+       ("python-robotframework-pythonlibcore"
+        ,python-robotframework-pythonlibcore)
+       ("python-selenium" ,python-selenium)))
+    (home-page "https://github.com/robotframework/SeleniumLibrary")
+    (synopsis "Web testing library for Robot Framework")
+    (description "SeleniumLibrary is a web testing library for Robot Framework
+that utilizes the Selenium tool internally.")
+    (license license:asl2.0)))
+
 (define-public python-rstr
   (package
    (name "python-rstr")