summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:32:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commitf3329764e2d3ffee7f0d177d33820c93e720b82e (patch)
tree7f2704f5139ba1b485c9794722f312d97befcf95 /gnu
parent1de36ea8d756113f4c2f86e4685c21b058125376 (diff)
downloadguix-f3329764e2d3ffee7f0d177d33820c93e720b82e.tar.gz
gnu: Add r-longdat.
* gnu/packages/cran.scm (r-longdat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ec07e401fa..c7a81b96eb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17847,6 +17847,48 @@ hierarchic loggers, multiple handlers per logger, level based filtering, space
 handling in messages and custom formatting.")
     (license license:gpl3)))
 
+(define-public r-longdat
+  (package
+    (name "r-longdat")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "LongDat" version))
+              (sha256
+               (base32
+                "1sqfmdv5agyvlw1y3yiv8kxi1040gq75qj4ln1jgb9lsmhdlfpyd"))))
+    (properties `((upstream-name . "LongDat")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bestnormalize
+                             r-car
+                             r-dplyr
+                             r-effsize
+                             r-emmeans
+                             r-ggplot2
+                             r-glmmtmb
+                             r-lme4
+                             r-magrittr
+                             r-mass
+                             r-patchwork
+                             r-reshape2
+                             r-rlang
+                             r-rstatix
+                             r-stringr
+                             r-tibble
+                             r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/CCY-dev/LongDat")
+    (synopsis
+     "Tool for covariate-sensitive longitudinal analysis on omics data")
+    (description
+     "This tool takes longitudinal dataset as input and analyzes if there is
+significant change of the features over time (a proxy for treatments), while
+detects and controls for covariates simultaneously.  LongDat is able to take
+in several data types as input, including count, proportion, binary, ordinal
+and continuous data.  The output table contains p values, effect sizes and
+covariates of each feature, making the downstream analysis easy.")
+    (license license:gpl2)))
+
 (define-public r-longitudinal
   (package
     (name "r-longitudinal")