summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-16 21:37:20 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-16 22:21:04 +0200
commitf678913cfe017da303a4f0ba04897b82f85010bd (patch)
tree2f0c57d329d9cda46d3615e083af00fcae0d837a /gnu
parent239c853c43fb3c6d3fa3bb9e38aafd8e800a1cdb (diff)
downloadguix-f678913cfe017da303a4f0ba04897b82f85010bd.tar.gz
gnu: libcmis: Propagate inputs.
* gnu/packages/libreoffice.scm (libcmis): Move curl and libxml2 from
  'inputs' to 'propagated-inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index dc0a365e63..23b1e2467c 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -223,11 +223,12 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
     (native-inputs
      `(("cppunit" ,cppunit)
        ("pkg-config" ,pkg-config)))
+    (propagated-inputs ; in Requires field of .pkg
+     `(("curl" ,curl)
+       ("libxml2" ,libxml2)))
     (inputs
      `(("boost" ,boost)
-       ("curl" ,curl)
        ("cyrus-sasl" ,cyrus-sasl)
-       ("libxml2" ,libxml2)
        ("openssl" ,openssl)))
     (arguments
      `(#:configure-flags