summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 20:10:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-06 18:37:59 +0100
commitfe994a0c328b456195fcf64443c28b2ca3f8da76 (patch)
treeee75eeb30298cbbbce48272386f5ce9d6ffefde9 /gnu
parent4a0c71f9f70fd2f2891848e272b3f81e3fabcf86 (diff)
downloadguix-fe994a0c328b456195fcf64443c28b2ca3f8da76.tar.gz
gnu: OpenLDAP: Remove cross-compilation workaround.
This is no longer required since the update to 2.4.49 in commit
090f33d6767dfc0b23d5e287369ec2dde331de01.

* gnu/packages/openldap.scm (openldap)[native-inputs]: Remove AUTOMAKE.
[arguments]: Remove 'fix-configure' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openldap.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 107b9239b8..60b543393e 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -87,9 +87,7 @@
              ("zlib" ,zlib)))
    (native-inputs `(("libtool" ,libtool)
                     ("groff" ,groff)
-                    ("bdb" ,bdb-5.3)
-                    ;; For up to date 'config.guess' and 'config.sub'.
-                    ("automake" ,automake)))
+                    ("bdb" ,bdb-5.3)))
    (arguments
     `(#:tests? #f
       #:configure-flags
@@ -102,20 +100,6 @@
       #:make-flags '("STRIP=")
       #:phases
       (modify-phases %standard-phases
-        (add-after 'unpack 'fix-configure
-          (lambda* (#:key inputs native-inputs #:allow-other-keys)
-            ;; Replace outdated config.sub and config.guess:
-            (with-directory-excursion "build"
-              (for-each (lambda (file)
-                          (install-file (string-append
-                                         (assoc-ref
-                                          (or native-inputs inputs) "automake")
-                                         "/share/automake-"
-                                         ,(version-major+minor
-                                           (package-version automake))
-                                         "/" file) "."))
-                        '("config.sub" "config.guess")))
-            #t))
         ,@(if (%current-target-system)
               '((add-before 'configure 'fix-cross-gcc
                   (lambda* (#:key target #:allow-other-keys)