summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-24 19:16:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-25 14:08:30 +0200
commitfea30e12f7b0810c90b278127a7d3c75ef59cec7 (patch)
tree054ef5aa009f3f170ef6d890a90b9a3e5f154844 /gnu
parente56d02a0e0108d68741f52d81e16bebcb2836332 (diff)
downloadguix-fea30e12f7b0810c90b278127a7d3c75ef59cec7.tar.gz
gnu: sparsehash: Don't use unstable tarball.
* gnu/packages/datastructures.scm (sparsehash)[source]: Download using
git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/datastructures.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index dabb1f421e..7eab65fd5f 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015, 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -80,12 +81,14 @@ library.")
     (name "sparsehash")
     (version "2.0.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/sparsehash/sparsehash/"
-                                  "archive/sparsehash-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sparsehash/sparsehash.git")
+                     (commit (string-append name "-" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "133szz0ldwch0kd91l0sa57qsnl020njn622szd9cxrjqyjqds85"))))
+                "0m3f0cnpnpf6aak52wn8xbrrdw8p0yhq8csgc8nlvf9zp8c402na"))))
     (build-system gnu-build-system)
     (synopsis "Memory-efficient hashtable implementations")
     (description