summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 16:08:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:05 -0400
commit04df12a9c3228900c604baf979d8c3560c4321bd (patch)
treee5c7acecdd7a6fb8d3738080c599891c48dce677 /gnu
parentfa836220b7b856cc8e658217a8d04b059af1e7e3 (diff)
downloadguix-04df12a9c3228900c604baf979d8c3560c4321bd.tar.gz
gnu: libhandy: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (libhandy) [arguments]: Remove
patch-docbook-xml phase.  Use gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 14 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 05e879e80a..35bdcd0698 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11819,30 +11819,20 @@ tabs, and it supports drag and drop re-ordering of terminals.")
         (base32 "1z8sbx7g19c1p8dy0sn0l25qfvrd2j28h269lsqm1y98r818h2k1"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags
-       '("-Dglade_catalog=enabled"
-         ;; XXX: Generating the documentation fails because the
-         ;; libhandy.devhelp2 document cannot be created. This seems to be
-         ;; caused by a problem during the XSL transformation.
-         "-Dgtk_doc=false")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-docbook-xml
-           (lambda* (#:key inputs #:allow-other-keys)
-             (for-each
-              (lambda (file)
-                (substitute* file
-                  (("http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd")
-                   (search-input-file inputs
-                                      "/xml/dtd/docbook/docbookx.dtd"))))
-              (find-files "doc" "\\.xml"))))
-         (add-before 'check 'pre-check
-           (lambda _
-             ;; Tests require a running X server.
-             (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1"))))))
-    (inputs
-     (list gtk+ glade3))
+     (list #:configure-flags
+           #~(list "-Dglade_catalog=enabled"
+                   ;; XXX: Generating the documentation fails because the
+                   ;; libhandy.devhelp2 document cannot be created. This seems
+                   ;; to be caused by a problem during the XSL transformation.
+                   "-Dgtk_doc=false")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'pre-check
+                 (lambda _
+                   ;; Tests require a running X server.
+                   (system "Xvfb :1 &")
+                   (setenv "DISPLAY" ":1"))))))
+    (inputs (list gtk+ glade3))
     (native-inputs
      (list gobject-introspection        ; for g-ir-scanner
            `(,glib "bin")