summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:08:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-04 15:08:36 +0200
commit16c2372fe8c04ad652101b60440f7bd76e51c0f9 (patch)
tree892cbda30a8010d64d47684e116ebcaaa769f9b5 /gnu
parent56892af033e0e5ac4087f2a22484cfe012430094 (diff)
downloadguix-16c2372fe8c04ad652101b60440f7bd76e51c0f9.tar.gz
gnu: tlpui: Honor TESTS?.
* gnu/packages/linux.scm (tlpui)[arguments]<#:phases>: Honor TESTS? in CHECK
phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 04684b05df..5e72040927 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7178,8 +7178,9 @@ every time the power supply source is changed.")
          ;; configuration from /etc/tlp.conf or /etc/default/tlp".
          (delete 'sanity-check)
          (replace 'check
-           (lambda _
-             (invoke "python" "-m" "discover")))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "discover"))))
          (add-after 'install 'wrap-gi-python
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))