summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrandon Lucas <br@ndon.dk>2022-01-23 13:42:43 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-23 17:58:11 +0100
commit1dbb8e930e9aa95e5fa8f2dd8241040650fe9486 (patch)
tree163767fa19db13028e431f57bb041b502775aeb2 /gnu
parent5e2bfd24a4d6f3cae4fe3ea4a692a2eba824a816 (diff)
downloadguix-1dbb8e930e9aa95e5fa8f2dd8241040650fe9486.tar.gz
gnu: Add emacs-fixed-pitch.
* gnu/packages/emacs-xyz.scm (emacs-fixed-pitch): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f63c45d57e..e30596fbd5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19672,6 +19672,29 @@ interactive behavior should be different.")
 decreasing the default font size in all GUI Emacs frames.")
     (license license:gpl3+)))
 
+(define-public emacs-fixed-pitch
+  (package
+    (name "emacs-fixed-pitch")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cstby/fixed-pitch-mode")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0qlavjvib0r71xdy6y6pan9dhr57lw7jhmqk60mwa8fq6km8kpkj"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/cstby/fixed-pitch-mode")
+    (synopsis
+     "Use a monospaced typeface for code and a proportional one elsewhere")
+    (description
+     "Fixed-pitch mode is an Emacs minor mode for setting a monospaced typeface.
+This allows you to set a proportional typeface for UI elements while keeping
+a monospaced typeface for code.")
+    (license license:gpl3+)))
+
 (define-public emacs-mixed-pitch
   (package
     (name "emacs-mixed-pitch")