summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:19:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:14 +0200
commit338510406311028ee19d6b6da948962436add294 (patch)
tree41b0f76504815c863e2874d2456654b01bb493ed /gnu
parent3ae611e95fe09306e1b0dddd742098c33a41c81f (diff)
downloadguix-338510406311028ee19d6b6da948962436add294.tar.gz
gnu: Add texlive-ucharcat.
* gnu/packages/tex.scm (texlive-ucharcat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 809c48ba15..edf56e7107 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7855,6 +7855,29 @@ It does not work in combination with list environments, but can be used in a
 
 (define-deprecated-package texlive-latex-wrapfig texlive-wrapfig)
 
+(define-public texlive-ucharcat
+  (package
+    (name "texlive-ucharcat")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ucharcat/"
+                   "source/latex/ucharcat/"
+                   "tex/latex/ucharcat/")
+             (base32
+              "0r6mphnn26053vb4bgw1zjhw7y7xjavii9hnn7607cbscnx5f9di")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ucharcat")
+    (synopsis
+     "Implementation of the XeTeX @code{\\Ucharcat} command for LuaTeX")
+    (description
+     "The package implements the @code{\\Ucharcat} command for LuaLaTeX.
+@code{\\Ucharcat} is a new primitive in XeTeX, an extension of the existing
+@code{\\Uchar} command, that allows the specification of the catcode as well
+as character code of the character token being constructed.")
+    (license license:lppl)))
+
 (define-public texlive-ucs
   (package
     (name "texlive-ucs")