summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-01-14 19:57:00 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-01-14 19:58:46 +0530
commit3a555a93a9f8e15095da8c79c7fa415ed21bf5b7 (patch)
tree1ce4074e396cde4b2f39f9d8b67de9e1905d5bdb /gnu
parent9d0d4b331d21cf555fdd6a8844d05389d934832c (diff)
downloadguix-3a555a93a9f8e15095da8c79c7fa415ed21bf5b7.tar.gz
gnu: crm114: Pass -fcommon to compiler.
* gnu/packages/mail.scm (crm114)[arguments]: Add -fcommon to CFLAGS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9f70ae1b08..b50224befd 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -17,7 +17,7 @@
 ;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
 ;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
 ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -4452,7 +4452,12 @@ ex-like commands on it.")
              ;; Inline functions can only be used from the same compilation
              ;; unit. This causes the build to fail.
              (substitute* "crm_svm_matrix.c"
-               (("^inline ") ""))))
+               (("^inline ") ""))
+             ;; Building with gcc 10 fails without the -fcommon flag. Add it
+             ;; to CFLAGS.
+             (substitute* "Makefile"
+               (("CFLAGS \\+= -DVERSION")
+                "CFLAGS += -fcommon -DVERSION"))))
          (add-before 'install 'pre-install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))