summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-07-03 22:52:19 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-07-18 20:23:42 +0800
commit3c79f4b50abba1e370da4d2a808cc6bfc4336654 (patch)
tree7b52b41fab0b3ad0d35d605dfd7240b18aab6ba8 /gnu
parentd1a76ac512cb0dab5fb8401e4d587f83042a7758 (diff)
downloadguix-3c79f4b50abba1e370da4d2a808cc6bfc4336654.tar.gz
gnu: ardour: Inline ardour-rpath-phase into its definition.
* gnu/packages/audio.scm (ardour)[#:phases]: Inline ardour-rpath-phase.
(ardour-rpath-phase): Delete variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2e2632f356..8a11d2d6cc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -721,21 +721,6 @@ streams from live audio.")
 purposes developed at Queen Mary, University of London.")
     (license license:gpl2+)))
 
-(define (ardour-rpath-phase major-version)
-  `(lambda* (#:key outputs #:allow-other-keys)
-     (let ((libdir (string-append (assoc-ref outputs "out")
-                                  "/lib/ardour" ,major-version)))
-       (substitute* "wscript"
-         (("linker_flags = \\[\\]")
-          (string-append "linker_flags = [\""
-                         "-Wl,-rpath="
-                         libdir ":"
-                         libdir "/backends" ":"
-                         libdir "/engines" ":"
-                         libdir "/panners" ":"
-                         libdir "/surfaces" ":"
-                         libdir "/vamp" "\"]"))))))
-
 (define ardour-bundled-media
   (origin
     (method url-fetch)
@@ -777,7 +762,20 @@ namespace ARDOUR { const char* revision = \"" version "\" ; const char* date = \
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-rpath-in-LDFLAGS
-          ,(ardour-rpath-phase (version-major version)))
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((libdir (string-append (assoc-ref outputs "out")
+                                          "/lib/ardour"
+                                          ,(version-major version))))
+               (substitute* "wscript"
+                 (("linker_flags = \\[\\]")
+                  (string-append "linker_flags = [\""
+                                 "-Wl,-rpath="
+                                 libdir ":"
+                                 libdir "/backends" ":"
+                                 libdir "/engines" ":"
+                                 libdir "/panners" ":"
+                                 libdir "/surfaces" ":"
+                                 libdir "/vamp" "\"]"))))))
          (add-after 'install 'install-freedesktop-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out   (assoc-ref outputs "out"))