summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:36:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:43:03 +0300
commit3ff615263c0105510ba74dae8541a28cad91499f (patch)
tree5d75f5d4c67de34599f1305510013748ef01292b /gnu
parentbc702a07c5dae6f04d70146a2c6bafffe9ddd865 (diff)
downloadguix-3ff615263c0105510ba74dae8541a28cad91499f.tar.gz
gnu: s7: Don't set #:tests? to #:true.
* gnu/packages/lisp.scm (s7)[arguments]: Rewrite to strip the #:tests?
argument from the inherited package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a868b31ecf..37735020ad 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017-2019, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2019, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2019–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
@@ -1315,7 +1315,7 @@ assembler, PEG) is less than 1MB.")
                                   (dirname
                                    (search-input-file
                                     inputs "include/stdlib.h"))))))
-  
+
                      (for-each wrap-carp-program
                                (list "carp"
                                      "carp-header-parse")))))))
@@ -1587,8 +1587,10 @@ be built as a stand-alone REPL interpreter.")
     (inherit s7-bootstrap)
     (name "s7")
     (arguments
-     (substitute-keyword-arguments (package-arguments s7-bootstrap)
-       ((#:tests? _) #t)
+     (substitute-keyword-arguments
+       (strip-keyword-arguments
+         '(#:tests?)
+         (package-arguments s7-bootstrap))
        ((#:phases phases)
         #~(modify-phases #$phases
             (add-after 'unpack 'patch