summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:59:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:28 +0200
commit6a7cf8060cb55386049f4e432910d5b1dba03bc3 (patch)
treecd60dc3e6205813feabde973d846cb41dbd5eb98 /gnu
parent8db7053537194058459dd4cb8bcadd76b73fb64e (diff)
downloadguix-6a7cf8060cb55386049f4e432910d5b1dba03bc3.tar.gz
gnu: Add texlive-luatextra.
* gnu/packages/tex.scm (texlive-luatextra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b6f3c4d4a..d35d641122 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16867,6 +16867,27 @@ outcome using this package rather than other Hangul macros operating on other
 engines.")
     (license license:lppl1.3c)))
 
+(define-public texlive-luatextra
+  (package
+    (name "texlive-luatextra")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/lualatex/luatextra/"
+                   "source/lualatex/luatextra/"
+                   "tex/lualatex/luatextra/")
+             (base32
+              "1i82x51rcdll5r6x63j5qqahb277a1xdrzpck30xlggwwlns0jdc")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/luatextra")
+    (synopsis "Additional macros for Plain TeX and LaTeX in LuaTeX")
+    (description
+     "The package provides a coherent extended programming environment for use
+with LuaTeX.  It loads packages @code{fontspec}, @code{luatexbase} and
+@code{lualibs}, and provides additional user-level features and goodies.")
+    (license license:public-domain)))
+
 (define-public texlive-babel-czech
   (package
     (name "texlive-babel-czech")