summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:05 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit735513e93e74b64ce680344c06c2190d6487130e (patch)
tree8810c8b53075be14de4990a2fe65153bfa8da60a /gnu
parent5a70b9b924444f8e238c546116045f4992faeffe (diff)
downloadguix-735513e93e74b64ce680344c06c2190d6487130e.tar.gz
gnu: python-pytest-filter-subpackage: Update to 0.1.2.
* gnu/packages/python-check.scm (python-pytest-filter-subpackage):
Update to 0.1.2.
[build-system]: Use pyproject-build-system.
[arguments]: Drop no more required phases.
[native-inputs]: Add python-setuptools-scm.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f17a51996e..3f2404c823 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -633,27 +633,19 @@ for interactively selecting and running Pytest tests.")
 (define-public python-pytest-filter-subpackage
   (package
     (name "python-pytest-filter-subpackage")
-    (version "0.1.1")
+    (version "0.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-filter-subpackage" version))
        (sha256
-        (base32 "1s4s2kd31yc65rfvl4xhy8xx806xhy59kc7668h6b6wq88xgrn5p"))))
-    (build-system python-build-system)
-    (arguments
-     '(;; One test is failing. There's an issue reported upstream. See
-       ;; https://github.com/astropy/pytest-filter-subpackage/issues/3.
-       ;; Disable it for now.
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Make the installed plugin discoverable by Pytest.
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "-k" "not test_with_rst"))))))
+        (base32 "10hpl3f7g2bm29lakmp8492b7lr0dp90khfni12m4gl02xks7bhz"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-pytest python-pytest-cov python-pytest-doctestplus))
+     (list python-pytest
+           python-pytest-cov
+           python-pytest-doctestplus
+           python-setuptools-scm))
     (home-page "https://github.com/astropy/pytest-filter-subpackage")
     (synopsis "Pytest plugin for filtering based on sub-packages")
     (description