summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-05-16 17:46:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-19 15:05:45 +0200
commit7bcf827c1d1a99097bea2dd309bdd5338e8de34a (patch)
tree587a5788fa992810debbfc2108dc5102cf210e70 /gnu
parent5d3675371c96fbda209b064fe3bef4a18592c3b9 (diff)
downloadguix-7bcf827c1d1a99097bea2dd309bdd5338e8de34a.tar.gz
gnu: python-botocore: Update to 1.12.149.
* gnu/packages/python-xyz.scm (python-botocore): Update to 1.12.149.
[native-inputs]: Add python-urllib3.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm55
1 files changed, 28 insertions, 27 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index be9c58bb98..2bf98222ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8428,34 +8428,35 @@ document.")
 
 (define-public python-botocore
   (package
-   (name "python-botocore")
-   (version "1.8.43")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "botocore" version))
-     (sha256
-      (base32
-       "12cqpbnz3vfv41mp9admvciw7bc7hz57sjpqs2bxaw9wnfmbw5lg"))))
-   (build-system python-build-system)
-   (arguments
-    ;; FIXME: Many tests are failing.
-    '(#:tests? #f))
-   (propagated-inputs
-    `(("python-dateutil" ,python-dateutil)
-      ("python-docutils" ,python-docutils)
-      ("python-jmespath" ,python-jmespath)))
-   (native-inputs
-    `(("python-mock" ,python-mock)
-      ("python-nose" ,python-nose)
-      ("behave" ,behave)
-      ("python-tox" ,python-tox)
-      ("python-wheel" ,python-wheel)))
-   (home-page "https://github.com/boto/botocore")
-   (synopsis "Low-level interface to AWS")
-   (description "Botocore is a Python library that provides a low-level
+    (name "python-botocore")
+    (version "1.12.149")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "botocore" version))
+       (sha256
+        (base32
+         "12597f74khp3ngwr282cb949w0gcqj20rkfc3x275dijavyy5cmf"))))
+    (build-system python-build-system)
+    (arguments
+     ;; FIXME: Many tests are failing.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-docutils" ,python-docutils)
+       ("python-jmespath" ,python-jmespath)))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)
+       ("behave" ,behave)
+       ("python-tox" ,python-tox)
+       ("python-urllib3" ,python-urllib3)
+       ("python-wheel" ,python-wheel)))
+    (home-page "https://github.com/boto/botocore")
+    (synopsis "Low-level interface to AWS")
+    (description "Botocore is a Python library that provides a low-level
 interface to the Amazon Web Services (AWS) API.")
-   (license license:asl2.0)))
+    (license license:asl2.0)))
 
 (define-public python2-botocore
   (package-with-python2 python-botocore))