summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2021-01-21 23:06:52 +0800
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-02 10:36:40 +0100
commit90ad8bd1a63abbf94f2ebb9f10630773d1f15ece (patch)
treed867e1d8278ade0e5fc8b993b72ed187880dd1a3 /gnu
parent625708b03a37fc2a33c437b8e27856ca76965f43 (diff)
downloadguix-90ad8bd1a63abbf94f2ebb9f10630773d1f15ece.tar.gz
gnu: ecl: Propagate some dependencies used in header files.
* gnu/packages/lisp.scm(ecl)[inputs]: Move gmp, libatomic-ops, libgc and
  libffi to...
  [propagated-inputs]: ... here.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3c09b0af8a..69011a3197 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -236,7 +236,13 @@ interface to the Tk widget system.")
      `(("cl-asdf" ,cl-asdf)
        ("which" ,which)
        ("texinfo" ,texinfo)))
-    (inputs
+    ;; When ECL is embedded in a program that wants to use Common Lisp as an
+    ;; extension language, libgmp, libatomic-ops, libgc and libffi must be
+    ;; present when compiling the program because they are required by ECL's
+    ;; header file.
+    ;; Therefore we put these libraries in 'propagated-inputs' instead
+    ;; of 'inputs'.
+    (propagated-inputs
      `(("gmp" ,gmp)
        ("libatomic-ops" ,libatomic-ops)
        ("libgc" ,libgc)