summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 14:38:57 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:06 +0000
commit9e6b25505ac07ffbf5ce16e4e08ae3dd626587b8 (patch)
tree672bf5409196bd6285dbf779141c23be7f6a0f39 /gnu
parent0d7888acf0791d1260ebf3f37ec50ad1dfcf359e (diff)
downloadguix-9e6b25505ac07ffbf5ce16e4e08ae3dd626587b8.tar.gz
gnu: graphene: Don't build introspection data when cross-compiling.
* gnu/packages/gtk.scm (graphene)[arguments]<#:configure-flags>: Set
  introspection=false when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d97a42f639..8a0c7c5f6e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2291,7 +2291,11 @@ Parcellite and adds bugfixes and features.")
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:configure-flags
        (list
-        "-Dinstalled_tests=false")))
+        "-Dinstalled_tests=false"
+        ,@(if (%current-target-system)
+              ;; Introspection requires running binaries for 'host' on 'build'.
+              '("-Dintrospection=false")
+              '()))))
     (native-inputs
      `(("git" ,git-minimal)
        ("gobject-introspection" ,gobject-introspection)