summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-11 16:24:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-12 14:13:17 +0200
commita1cb645d83d085382eaf64f4c097642aa47c297a (patch)
tree939eec6ed227b8a49469508f3d344d863c63bf59 /gnu
parent2936acfb37d87d33f1e879a63795aa7c65affb07 (diff)
downloadguix-a1cb645d83d085382eaf64f4c097642aa47c297a.tar.gz
gnu: python-packaging-bootstrap: Add python2-variant property.
* gnu/packages/python-build.scm (python-packaging-bootstrap)[properties]: Add
python2-variant.
(python2-packaging-bootstrap): Strip python2-variant property.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-build.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 2abb781f76..eb291c2c86 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2018, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -309,10 +309,12 @@ information.")
     ;; *either* of the licenses found in LICENSE.APACHE or LICENSE.BSD.
     ;; Contributions to this software is made under the terms of *both* these
     ;; licenses.
-    (license (list license:asl2.0 license:bsd-2))))
+    (license (list license:asl2.0 license:bsd-2))
+    (properties `((python2-variant . ,(delay python2-packaging-bootstrap))))))
 
 (define-public python2-packaging-bootstrap
-  (let ((base (package-with-python2 python-packaging-bootstrap)))
+  (let ((base (package-with-python2
+               (strip-python2-variant python-packaging-bootstrap))))
     (package/inherit base
       (version "20.0")                  ;last version with Python 2 support
       (source