summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-04 15:22:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-11 10:18:54 +0100
commita6499572b3cc564c197bc86d36a23ed7034944b8 (patch)
tree7d126cc19b5f582a61d52f7c2f5f4096bfd8d18e /gnu
parent2a5ed25c412e162505b2b371d00987fd158a91d4 (diff)
downloadguix-a6499572b3cc564c197bc86d36a23ed7034944b8.tar.gz
gnu: texlive-bin: Patch references to sed and awk.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Patch texlive scripts in
'post-install phase to satisfy references to sed and awk.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f1aedaa19..f75b61a59a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -498,6 +498,14 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
                                   source "/texlive-scripts/source/")
                                  scripts)
 
+               ;; Patch them.
+               (let ((dirs (map dirname (list (which "sed") (which "awk")))))
+                 (with-directory-excursion scripts
+                   (substitute* '("mktexpk" "mktexmf" "mktexlsr")
+                     (("^version=" m)
+                      (format #false "PATH=\"~{~a:~}$PATH\"; export PATH~%~a"
+                              dirs m)))))
+
                ;; Make sure that fmtutil can find its Perl modules.
                (substitute* (string-append scripts "/fmtutil.pl")
                  (("\\$TEXMFROOT/")