summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:06:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:07 +0200
commita8a990ff0e8855218a88854d40129173d0ca48f1 (patch)
tree1240448c5f00f227c0221a28fd72e54f7f0b814e /gnu
parent65a17e01f493f955880abf960e8eae9da69713fe (diff)
downloadguix-a8a990ff0e8855218a88854d40129173d0ca48f1.tar.gz
gnu: Add texlive-euler.
* gnu/packages/tex.scm (texlive-euler): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d077978e9..d91a18c977 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8511,6 +8511,29 @@ format.")
 
 (define-deprecated-package texlive-latex-eukdate texlive-eukdate)
 
+(define-public texlive-euler
+  (package
+    (name "texlive-euler")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/euler/" "source/latex/euler/"
+                   "tex/latex/euler/")
+             (base32
+              "0xd4lniaj243jvmlgfan7rp1zx308cfvpdd02nvvqpdnrwc69irk")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/euler")
+    (synopsis "Use AMS Euler fonts for math")
+    (description
+     "This package provides a setup for using the AMS Euler family of fonts
+for mathematics in LaTeX documents. ``The underlying philosophy of Zapf's
+Euler design was to capture the flavour of mathematics as it might be written
+by a mathematician with excellent handwriting.'' The @code{euler} package is
+based on Knuth's macros for the book Concrete Mathematics'.  The text fonts
+for the Concrete book are supported by the @code{beton} package.")
+    (license license:lppl)))
+
 (define-public texlive-ulem
   (package
     (name "texlive-ulem")