summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:00 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:08 +0300
commitbb38261b5d878ef93a72ca82bf8312767dde0d17 (patch)
treeb37e8efad5144f99c2341cea5a008eca7567029b /gnu
parent476f764f0711798a8c3cd22787545ae548af02fb (diff)
downloadguix-bb38261b5d878ef93a72ca82bf8312767dde0d17.tar.gz
gnu: python-pytest-doctestplus: Update to 0.12.1.
* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to
0.12.1.
[build-system]: Use pyproject-build-system.
[arguments]<phases>: Remove modify-phases and add test-flags option
instead.
[native-inputs]: Add python-numpy.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 91a01df2ce..f17a51996e 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -577,32 +577,25 @@ are too large to conveniently hard-code them in the tests.")
 (define-public python-pytest-doctestplus
   (package
     (name "python-pytest-doctestplus")
-    (version "0.11.2")
+    (version "0.12.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-doctestplus" version))
        (sha256
-        (base32 "0j1lvlj3ps975q9hmg8i6rpqm0313j3r18bc3l8mz6khb7vav4zk"))))
-    (build-system python-build-system)
+        (base32 "10ciqylgziihxwxryxvxgmkqgws51pqcarn0gbh1d4cxx55rx5vs"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             ;; Make the installed plugin discoverable by Pytest.
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest" "-k"
-                       (string-append   ; skip tests that require remote data
-                        "not test_remote_data_url"
-                        " and not test_remote_data_float_cmp"
-                        " and not test_remote_data_ignore_whitespace"
-                        " and not test_remote_data_ellipsis"
-                        " and not test_remote_data_requires"
-                        " and not test_remote_data_ignore_warnings"))))))))
+     (list #:test-flags
+           #~(list "-k" (string-append
+                         "not test_remote_data_url"
+                         " and not test_remote_data_float_cmp"
+                         " and not test_remote_data_ignore_whitespace"
+                         " and not test_remote_data_ellipsis"
+                         " and not test_remote_data_requires"
+                         " and not test_remote_data_ignore_warnings"))))
     (native-inputs
-     (list python-pytest python-setuptools-scm))
+     (list python-numpy python-pytest python-setuptools-scm))
     (home-page "https://github.com/astropy/pytest-doctestplus")
     (synopsis "Pytest plugin with advanced doctest features")
     (description