summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 21:13:14 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:39 -0800
commitbb7518b1e8c579648919fe2b2195a0a3111e471c (patch)
treea5849fda87ef6cf0d132fa3814756ae8d174d8f5 /gnu
parent778a284be51d797497701444365d14fa877c1abc (diff)
downloadguix-bb7518b1e8c579648919fe2b2195a0a3111e471c.tar.gz
gnu: Add python-pastedeploy.
* gnu/packages/python.scm (python-pastedeploy, python2-pastedeploy):
  New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cad14c189c..c7e0e14ce3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7744,3 +7744,34 @@ and to spawn subprocesses to handle requests.")
       (inherit wsgiproxy2)
       (inputs `(("python2-setuptools" ,python2-setuptools)
                 ,@(package-inputs wsgiproxy2))))))
+
+(define-public python-pastedeploy
+  (package
+    (name "python-pastedeploy")
+    (version "1.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PasteDeploy" version))
+       (sha256
+        (base32
+         "1jz3m4hq8v6hyhfjz9425nd3nvn52cvbfipdcd72krjmla4qz1fm"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (propagated-inputs
+     ;; This package uses pkg_resources, part of setuptools, during runtime,
+     ;; hence why not a native-input.
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://pythonpaste.org/deploy/")
+    (synopsis
+     "Load, configure, and compose WSGI applications and servers")
+    (description
+     "This tool provides code to load WSGI applications and servers from URIs;
+these URIs can refer to Python Eggs for INI-style configuration files.  Paste
+Script provides commands to serve applications based on this configuration
+file.")
+    (license license:expat)))
+
+(define-public python2-pastedeploy
+  (package-with-python2 python-pastedeploy))