summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-18 12:43:10 +0900
committerLudovic Courtès <ludo@gnu.org>2023-06-21 00:10:50 +0200
commitda4305e9b3d65cf698a6987bd7be7905785bf06c (patch)
tree10ffa3ba8972dc56820bf681d765f3d6215f1bf9 /gnu
parentd67c85324dedcc33a56b146c8a51b5eec83aafe9 (diff)
downloadguix-da4305e9b3d65cf698a6987bd7be7905785bf06c.tar.gz
gnu: go-github-com-mattn-go-runewidth: Update to 0.0.14.
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Update to 0.0.14.
(go-github.com-mattn-go-runewidth): Remove, and change users to to refer
to 'go-github-com-mattn-go-runewidth'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/configuration-management.scm2
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/disk.scm2
-rw-r--r--gnu/packages/golang.scm18
-rw-r--r--gnu/packages/terminals.scm4
-rw-r--r--gnu/packages/textutils.scm28
-rw-r--r--gnu/packages/time.scm2
7 files changed, 15 insertions, 43 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index b66f70545a..95a7e8615f 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -78,7 +78,7 @@
            go-github-com-google-goterm
            go-github-com-lucasb-eyer-go-colorful
            go-github-com-mattn-go-isatty
-           go-github.com-mattn-go-runewidth
+           go-github-com-mattn-go-runewidth
            go-github-com-olekukonko-tablewriter
            go-github-com-pelletier-go-toml
            go-github-com-pkg-diff
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9928ede40e..42b394daf2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5072,7 +5072,7 @@ compatible with SQLite using a graphical user interface.")
                   go-github-com-pkg-errors
                   go-github-com-sourcegraph-jsonrpc2
                   go-golang-org-x-crypto
-                  go-github.com-mattn-go-runewidth
+                  go-github-com-mattn-go-runewidth
                   go-golang-org-x-xerrors
                   go-gopkg-in-yaml-v2))
     (synopsis "SQL language server written in Go")
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index abbc87a95a..b878614dc2 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1161,7 +1161,7 @@ on your file system and offers to remove it.  @command{rmlint} can find:
                 "1piym8za0iw2s8yryh39y072f90mzisv89ffvn1jzb71f71mbfqa"))))
     (build-system go-build-system)
     (native-inputs
-     (list go-github.com-mattn-go-runewidth go-golang-org-x-term
+     (list go-github-com-mattn-go-runewidth go-golang-org-x-term
            go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2-2.3))
     (arguments
      `(#:import-path "github.com/gokcehan/lf"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d51c023808..b99659966d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2755,7 +2755,7 @@ jar struct to manage the cookies added to the cookie jar.")
      '(#:unpack-path "github.com/gizak/termui"
        #:import-path "github.com/gizak/termui/v3"))
     (propagated-inputs
-     (list go-github.com-mattn-go-runewidth
+     (list go-github-com-mattn-go-runewidth
            go-github-com-mitchellh-go-wordwrap go-github.com-nsf-termbox-go))
     (home-page "https://github.com/gizak/termui")
     (synopsis "Terminal dashboard widget Go library")
@@ -7105,7 +7105,7 @@ encoding in Go.")
       (arguments
        `(#:import-path "github.com/gdamore/tcell"))
       (inputs
-       (list go-github.com-mattn-go-runewidth
+       (list go-github-com-mattn-go-runewidth
              go-github-com-lucasb-eyer-go-colorful
              go-golang-org-x-text
              go-github-com-gdamore-encoding))
@@ -9128,7 +9128,7 @@ transforms one JSON document into another through a JMESPath expression.")
      `(#:import-path "github.com/muesli/reflow/wordwrap"
        #:unpack-path "github.com/muesli/reflow"))
     (native-inputs
-     (list go-github.com-mattn-go-runewidth))
+     (list go-github-com-mattn-go-runewidth))
     (home-page "https://github.com/muesli/reflow/")
     (synopsis "Collection of methods helping to transform blocks of text")
     (description "This package provides a collection of ANSI-aware methods and
@@ -9187,7 +9187,7 @@ io.Writers helping you to transform blocks of text.")
      (list go-github-com-google-goterm
            go-github-com-lucasb-eyer-go-colorful
            go-github-com-mattn-go-isatty
-           go-github.com-mattn-go-runewidth))
+           go-github-com-mattn-go-runewidth))
     (home-page "https://github.com/muesli/termenv/")
     (synopsis "Advanced styling options on the terminal")
     (description "termenv lets you safely use advanced styling options on the
@@ -9241,7 +9241,7 @@ which produce colorized output using github.com/fatih/color.")
     (arguments
      `(#:import-path "github.com/olekukonko/tablewriter"))
     (propagated-inputs
-     (list go-github.com-mattn-go-runewidth))
+     (list go-github-com-mattn-go-runewidth))
     (home-page "https://github.com/olekukonko/tablewriter/")
     (synopsis "Generate ASCII table")
     (description "This package generates ASCII tables.  Features:
@@ -9338,7 +9338,7 @@ size of the terminal.")
            go-github-com-muesli-reflow-wordwrap
            go-github-com-muesli-reflow-indent
            go-github-com-muesli-reflow-padding
-           go-github.com-mattn-go-runewidth
+           go-github-com-mattn-go-runewidth
            go-github-com-muesli-termenv
            go-github-com-google-goterm
            go-github-com-lucasb-eyer-go-colorful
@@ -11521,7 +11521,7 @@ averages.")
 (define-public go-github-com-mattn-go-runewidth
   (package
     (name "go-github-com-mattn-go-runewidth")
-    (version "0.0.13")
+    (version "0.0.14")
     (source
      (origin
        (method git-fetch)
@@ -11530,7 +11530,7 @@ averages.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1yir0f3wc5z5hnkwhvx5qb6nmpfb05zp2gvfjvna63s8kmla1rrn"))))
+        (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
     (build-system go-build-system)
     (arguments '(#:import-path "github.com/mattn/go-runewidth"))
     (propagated-inputs
@@ -11563,7 +11563,7 @@ string.")
     (propagated-inputs
      `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
        ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
-       ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+       ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
        ("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
        ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
        ("go-github-com-lucasb-eyer-go-colorful" ,go-github-com-lucasb-eyer-go-colorful)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 9831ddbe2b..a3fa39e5da 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -992,7 +992,7 @@ minimalistic.")
       (arguments
        '(#:import-path "github.com/nsf/termbox-go"))
       (propagated-inputs
-       (list go-github.com-mattn-go-runewidth))
+       (list go-github-com-mattn-go-runewidth))
       (synopsis "@code{termbox} provides a minimal API for text-based user
 interfaces")
       (description
@@ -1019,7 +1019,7 @@ programmer to write text-based user interfaces.")
     (arguments
      `(#:import-path "github.com/junegunn/fzf"))
     (inputs
-     (list go-github.com-mattn-go-runewidth
+     (list go-github-com-mattn-go-runewidth
            go-github-com-mattn-go-shellwords
            go-github-com-mattn-go-isatty
            go-github-com-gdamore-tcell
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index ba33cf7de7..51df3748cd 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1008,34 +1008,6 @@ and Cython.")
 markup and converts it to multiple formats.")
     (license license:gpl2)))
 
-(define-public go-github.com-mattn-go-runewidth
-  (let ((commit "703b5e6b11ae25aeb2af9ebb5d5fdf8fa2575211")
-        (version "0.0.4")
-        (revision "1"))
-    (package
-      (name "go-github.com-mattn-go-runewidth")
-      (version (git-version version revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/mattn/runewidth")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0znpyz71gajx3g0j2zp63nhjj2c07g16885vxv4ykwnrfmzbgk4w"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/mattn/go-runewidth"))
-      (synopsis "@code{runewidth} provides Go functions to work with string widths")
-      (description
-       "The @code{runewidth} library provides Go functions for padding,
-measuring and checking the width of strings, with support for East Asian
-text.")
-      (home-page "https://github.com/mattn/runewidth")
-      (license license:expat))))
-
 (define-public docx2txt
   (package
     (name "docx2txt")
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 38b51583da..5c8f65a1e6 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -623,7 +623,7 @@ TUI program that displays time across a few time zones of your choosing.")
     (arguments
      '(#:import-path "github.com/antonmedv/countdown"))
     (native-inputs
-     `(("runewidth" ,go-github.com-mattn-go-runewidth)
+     `(("runewidth" ,go-github-com-mattn-go-runewidth)
        ("termbox" ,go-github.com-nsf-termbox-go)))
     (home-page "https://github.com/antonmedv/countdown")
     (synopsis "Counts to zero with a text user interface")