summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-12 23:56:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-13 00:00:42 +0300
commite37415917c4758142c052cae46b3d84517b54ec2 (patch)
tree6c7a2698ff0ee5b8d04d249cd41aff138e0de101 /gnu
parent4e169fc67aa6bb24403e28a8cd02bf77dc37b1da (diff)
downloadguix-e37415917c4758142c052cae46b3d84517b54ec2.tar.gz
gnu: python-psycopg2: Update to 2.7.3.1.
* gnu/packages/python.scm (python-psycopg2): Update to 2.7.3.1.
[inputs]: Replace postgresql@9.6 with postgresql.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 12d4dd21a7..44504e3833 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10815,21 +10815,21 @@ introspection of @code{zope.interface} instances in code.")
 (define-public python-psycopg2
   (package
     (name "python-psycopg2")
-    (version "2.6.2")
+    (version "2.7.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "psycopg2" version))
        (sha256
         (base32
-         "0p60z2gwfcal30y2w8gprflchp1kcg9qblc5rn782p4wxl90wjbh"))))
+         "0rda1j02ds6s28752fhmpwg761sh6jsxi1gpczqkrd28cki1cywv"))))
     (build-system python-build-system)
     (arguments
      ;; Tests would require a postgresql database "psycopg2_test"
      ;; and a running postgresql database management service.
      `(#:tests? #f)) ; TODO re-enable after providing a test-db.
     (inputs
-     `(("postgresql" ,postgresql-9.6))) ; libpq
+     `(("postgresql" ,postgresql))) ; libpq
     (home-page "http://initd.org/psycopg/")
     (synopsis "Python PostgreSQL adapter")
     (description