summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-26 21:45:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-26 21:57:31 -0400
commite6480571a094e27dc50db2b42334f17a6d1957d4 (patch)
tree27e0c0829da24cb2ffe245ce3e2dd4306a694b5d /gnu
parentac65e3029bba3507844d69cc0e302705cdf7addf (diff)
downloadguix-e6480571a094e27dc50db2b42334f17a6d1957d4.tar.gz
gnu: opendht: Really disable the problematic testListen test.
* gnu/packages/networking.scm (opendht)
[phases]{disable-problematic-tests}: Adjust regexp pattern.

Reported-by: Jack Hill <jackhill@jackhill.us>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9101aac472..3249bddbb2 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3506,8 +3506,8 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
               ;; on, introducing nondeterminism (see:
               ;; https://github.com/savoirfairelinux/opendht/issues/626).
               (substitute* "tests/Makefile.am"
-                (("tests/dhtrunnertester.(h|cpp)$" all)
-                 (string-append "# " all)))))
+                (("\\bdhtrunnertester\\.(h|cpp)\\b")
+                 ""))))
           (add-after 'unpack 'fix-python-installation-prefix
             ;; Specify the installation prefix for the compiled Python module
             ;; that would otherwise attempt to installs itself to Python's own