summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 20:47:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commite652b44725d910169f0281f04d447074512efca1 (patch)
tree529c141cbd164bd6eee92e3931ee256a6f341092 /gnu
parente2eb43f945fd467e9b55a4b3c91cd186cf32e268 (diff)
downloadguix-e652b44725d910169f0281f04d447074512efca1.tar.gz
gnu: python-pytorch: Update to 1.13.1.
* gnu/packages/machine-learning.scm (python-pytorch): Update to  1.13.1.
[source]: Update snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8c912cf2da..d630fe090e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3271,7 +3271,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
 (define-public python-pytorch
   (package
     (name "python-pytorch")
-    (version "1.12.0")
+    (version "1.13.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3281,7 +3281,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0pdqi91qzgyx947zv4pw2fdj9vpqvdhfzw1ydjd4mpqm8g5njgnz"))
+                "17yxjzwp4zp75fz7czgz9acijzw7dpyqcza50v8y1x7hfg2gw369"))
               (patches (search-patches "python-pytorch-system-libraries.patch"
                                        "python-pytorch-runpath.patch"))
               (modules '((guix build utils)))
@@ -3301,7 +3301,10 @@ TensorFlow.js, PyTorch, and MediaPipe.")
                               "gloo" "googletest" "ios-cmake" "NNPACK"
                               "onnx" "protobuf" "pthreadpool"
                               "pybind11" "python-enum" "python-peachpy"
-                              "python-six" "tbb" "XNNPACK" "zstd"))))))
+                              "python-six" "tbb" "XNNPACK" "zstd"))
+                  (substitute* "functorch/CMakeLists.txt"
+                    (("\\$\\{_rpath_portable_origin\\}/../torch/lib")
+                     "$ORIGIN/../torch/lib"))))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases