summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 18:29:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 18:48:30 +0100
commitec4382ebf355eb5de22b85b1be48f625f2b2ea7f (patch)
tree23f5b0a3c9f7efaa0f0f989d5bfe3cd04bb63da5 /gnu
parent63e8b845282e5750bfe5cc1466af31506482e377 (diff)
downloadguix-ec4382ebf355eb5de22b85b1be48f625f2b2ea7f.tar.gz
gnu: Add r-gillespiessa2.
* gnu/packages/cran.scm (r-gillespiessa2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 25c5cb2e60..1ac9e4b033 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11903,6 +11903,42 @@ files to an structured list.  Users can manipulate this resulting list with
 back to file after modifications.")
     (license license:gpl3)))
 
+(define-public r-gillespiessa2
+  (package
+    (name "r-gillespiessa2")
+    (version "0.2.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "GillespieSSA2" version))
+       (sha256
+        (base32 "03ym8qx5yc1a6j9l973lc0rjzs8hiax8fq13j7m1fcb1pvnbvar5"))))
+    (properties `((upstream-name . "GillespieSSA2")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-assertthat
+           r-dplyr
+           r-dynutils
+           r-matrix
+           r-purrr
+           r-rcpp
+           r-rcppxptrutils
+           r-readr
+           r-rlang
+           r-stringr
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/rcannood/GillespieSSA2")
+    (synopsis "Gillespie's stochastic simulation algorithm")
+    (description
+     "This package provides a fast, scalable, and versatile framework for
+simulating large systems with Gillespie's @dfn{Stochastic Simulation
+Algorithm} (SSA).  This package is the spiritual successor to the GillespieSSA
+package.  Benefits of this package include major speed improvements (>100x),
+easier to understand documentation, and many unit tests that try to ensure the
+package works as intended.")
+    (license license:gpl3+)))
+
 (define-public r-gitcreds
   (package
     (name "r-gitcreds")