summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:29 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:45:32 -0500
commitecc9c4c3f6a7cb88038d80729deafaba991f56f1 (patch)
tree50ca23e8839c0afe63be09ea55d22d0c12401415 /gnu
parent1cce28235dda2eb85ab8e4e2f813ac901666e4a3 (diff)
downloadguix-ecc9c4c3f6a7cb88038d80729deafaba991f56f1.tar.gz
gnu: Add go-gopkg-in-tomb-v1.
* gnu/packages/golang.scm (go-gopkg-in-tomb-v1): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d2357e4690..bfc1e6ad05 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2665,6 +2665,32 @@ termination.")
       (home-page "https://gopkg.in/tomb.v2")
       (license license:bsd-3))))
 
+(define-public go-gopkg-in-tomb-v1
+  (package
+    (inherit go-gopkg.in-tomb.v2)
+    (name "go-gopkg-in-tomb-v1")
+    (version "1.0.0-20141024135613-dd632973f1e7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gopkg.in/tomb.v1")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lqmq1ag7s4b3gc3ddvr792c5xb5k6sfn0cchr3i2s7f1c231zjv"))))
+    (arguments
+     (list #:import-path "gopkg.in/tomb.v1"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-test
+                 (lambda* (#:key import-path #:allow-other-keys)
+                   (substitute* (string-append "src/" import-path
+                                               "/tomb_test.go")
+                     (("t.Fatalf\\(`Killf\\(\"BO%s")
+                      "t.Fatalf(`Killf(\"BO%%s")))))))
+    (home-page "https://gopkg.in/tomb.v1")))
+
 (define-public go-gopkg-in-natefinch-lumberjack.v2
   (package
     (name "go-gopkg-in-natefinch-lumberjack.v2")