summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-08-12 17:33:00 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-08-12 17:43:20 +0200
commiteecb5efad92b8f7cb5bbea0be66c4707a749512c (patch)
tree1fd780c408bdc98ed5863cf8d2d1bd1dd9ba3b55 /gnu
parentfc408acd61022d1db366bd1cec9ba1537773dfa1 (diff)
downloadguix-eecb5efad92b8f7cb5bbea0be66c4707a749512c.tar.gz
gnu: monero-gui: Fix path to p2pool.
Fixes <https://issues.guix.gnu.org/55512>.

* gnu/packages/finance.scm (monero-gui)[inputs]: Add p2pool.
  [arguments]: Add 'fix-p2pool-path' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 55a2dd9580..c72d7a1429 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -837,6 +837,7 @@ the Monero command line client and daemon.")
      (modify-inputs (package-inputs monero)
        (append libgcrypt
                monero
+               p2pool
                qtbase-5
                qtdeclarative-5
                qtgraphicaleffects
@@ -870,6 +871,17 @@ the Monero command line client and daemon.")
                       (string-append
                        "set(CMAKE_C_FLAGS \"${CMAKE_C_FLAGS} -fPIC\")\n"
                        all)))))
+               (add-after 'unpack 'fix-p2pool-path
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "src/p2pool/P2PoolManager.cpp"
+                     ;; Location for files created by P2Pool
+                     (("m_p2poolPath = QApplication::applicationDirPath\\(\\);")
+                      "m_p2poolPath = QStandardPaths::writableLocation(QStandardPaths::CacheLocation);")
+                     ;; Location of p2pool program
+                     (("m_p2pool = m_p2poolPath \\+ \"/p2pool\";")
+                      (string-append "m_p2pool = \""
+                                     (search-input-file inputs "/bin/p2pool")
+                                     "\";")))))
                (replace 'install
                  (lambda _
                    (let ((bin (string-append #$output "/bin")))